import re
regex = re.compile(r"\b's\b", flags=re.MULTILINE)
test_str = "Python's Programming: is very easy to learn in str."
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)