package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*?\bFlorida\b)?.*?\b(Florida\b.*)`)
var str = `Arkansas; Hawaii; South Dakota; North Carolina
California;Florida; Washington State; New York; Florida; West Virginia; DC
Nevada; Texas; New Mexico; Georgia
Florida
Florida Florida Florida`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}