$re = '/^(?:.*?\bFlorida\b)?.*?\b(Florida\b.*)/m';
$str = 'Arkansas; Hawaii; South Dakota; North Carolina
California;Florida; Washington State; New York; Florida; West Virginia; DC
Nevada; Texas; New Mexico; Georgia
Florida
Florida Florida Florida';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);