const regex = /^(?:.*?\bFlorida\b)?.*?\b(Florida\b.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*?\\bFlorida\\b)?.*?\\b(Florida\\b.*)', 'gm')
const str = `Arkansas; Hawaii; South Dakota; North Carolina
California;Florida; Washington State; New York; Florida; West Virginia; DC
Nevada; Texas; New Mexico; Georgia
Florida
Florida Florida Florida`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}