import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?\\bFlorida\\b)?.*?\\b(Florida\\b.*)";
final String string = "Arkansas; Hawaii; South Dakota; North Carolina\n"
+ "California;Florida; Washington State; New York; Florida; West Virginia; DC\n"
+ "Nevada; Texas; New Mexico; Georgia\n\n"
+ "Florida\n\n"
+ "Florida Florida Florida";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}