// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*?\bFlorida\b)?.*?\b(Florida\b.*)").unwrap();
let string = "Arkansas; Hawaii; South Dakota; North Carolina
California;Florida; Washington State; New York; Florida; West Virginia; DC
Nevada; Texas; New Mexico; Georgia
Florida
Florida Florida Florida";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}