import re
regex = re.compile(r"^(?:.*?\bFlorida\b)?.*?\b(Florida\b.*)", flags=re.MULTILINE)
test_str = ("Arkansas; Hawaii; South Dakota; North Carolina\n"
"California;Florida; Washington State; New York; Florida; West Virginia; DC\n"
"Nevada; Texas; New Mexico; Georgia\n\n"
"Florida\n\n"
"Florida Florida Florida")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")