#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^.+\t+\n)[\w\d\n ]+(?=^.+\t+\n|$)"
Local $sString = "SA DOG:犬 " & @CRLF & _
"sa1 bob" & @CRLF & _
"sa2" & @CRLF & _
"HEADING2 " & @CRLF & _
"after the 2nd heading" & @CRLF & _
"line" & @CRLF & _
"3RD FINAL HEADING " & @CRLF & _
"blah blah" & @CRLF & _
"blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")