import re
regex = re.compile(r"(?<=^.+\t+\n)[\w\d\n ]+(?=^.+\t+\n|$)", flags=re.MULTILINE)
test_str = ("SA DOG:犬 \n"
"sa1 bob\n"
"sa2\n"
"HEADING2 \n"
"after the 2nd heading\n"
"line\n"
"3RD FINAL HEADING \n"
"blah blah\n"
"blah blah")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")