using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^.+\t+\n)[\w\d\n ]+(?=^.+\t+\n|$)";
string input = @"SA DOG:犬
sa1 bob
sa2
HEADING2
after the 2nd heading
line
3RD FINAL HEADING
blah blah
blah blah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}