$re = '/(?<=^.+\t+\n)[\w\d\n ]+(?=^.+\t+\n|$)/m';
$str = 'SA DOG:犬
sa1 bob
sa2
HEADING2
after the 2nd heading
line
3RD FINAL HEADING
blah blah
blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);