import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^.+\\t+\\n)[\\w\\d\\n ]+(?=^.+\\t+\\n|$)";
final String string = "SA DOG:犬 \n"
+ "sa1 bob\n"
+ "sa2\n"
+ "HEADING2 \n"
+ "after the 2nd heading\n"
+ "line\n"
+ "3RD FINAL HEADING \n"
+ "blah blah\n"
+ "blah blah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}