const regex = /(?<=^.+\t+\n)[\w\d\n ]+(?=^.+\t+\n|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^.+\\t+\\n)[\\w\\d\\n ]+(?=^.+\\t+\\n|$)', 'gm')
const str = `SA DOG:犬
sa1 bob
sa2
HEADING2
after the 2nd heading
line
3RD FINAL HEADING
blah blah
blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}