using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(?P<type>.+)\]\:\ (?P<subject>(.+)\.)(?=[\r\n|\r|\n]*Description)";
string input = @"[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 478.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas,
asdjasdaskdaskdhaslkjdlasjdkasd.
Reference: #232
^\[(?P<type>.+)\]\:\ (?P<subject>(.|\r\n|\r|\n)+\.$)(?=[\r\n|\r|\n]*Description) => ~13ms (5k steps) /gm
^\[(?P<type>.+)\]\:\ (?P<subject>(.*)\.)(?=[\r\n|\r|\n]*Description) => ~5ms (1-2k steps) /gs
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}