import re
regex = re.compile(r"^\[(?P<type>.+)\]\:\ (?P<subject>(.+)\.)(?=[\r\n|\r|\n]*Description)", flags=re.DOTALL)
test_str = ("[FIX]: Fix bad wiring on plane 334, 335,\n"
"and 336. Remove decorator for 478.\n\n"
"Description:\n"
"1. sadsadad.\n"
"2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.\n"
"3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas,\n"
"asdjasdaskdaskdhaslkjdlasjdkasd.\n\n"
"Reference: #232\n\n"
"^\\[(?P<type>.+)\\]\\:\\ (?P<subject>(.|\\r\\n|\\r|\\n)+\\.$)(?=[\\r\\n|\\r|\\n]*Description) => ~13ms (5k steps) /gm\n\n"
"^\\[(?P<type>.+)\\]\\:\\ (?P<subject>(.*)\\.)(?=[\\r\\n|\\r|\\n]*Description) => ~5ms (1-2k steps) /gs\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")