$re = '/^\[(?P<type>.+)\]\:\ (?P<subject>(.+)\.)(?=[\r\n|\r|\n]*Description)/s';
$str = '[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 478.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas,
asdjasdaskdaskdhaslkjdlasjdkasd.
Reference: #232
^\\[(?P<type>.+)\\]\\:\\ (?P<subject>(.|\\r\\n|\\r|\\n)+\\.$)(?=[\\r\\n|\\r|\\n]*Description) => ~13ms (5k steps) /gm
^\\[(?P<type>.+)\\]\\:\\ (?P<subject>(.*)\\.)(?=[\\r\\n|\\r|\\n]*Description) => ~5ms (1-2k steps) /gs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);