using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"capacity of \d+\.\d+(*SKIP)(*FAIL)|\d+\.\d+";
string input = @"A car has 34.5 gallons, milleage capacity of 60.7 and a cost of 2000.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}