package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)capacity of \d+\.\d+(*SKIP)(*FAIL)|\d+\.\d+`)
var str = `A car has 34.5 gallons, milleage capacity of 60.7 and a cost of 2000.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}