$re = '/capacity of \d+\.\d+(*SKIP)(*FAIL)|\d+\.\d+/m';
$str = 'A car has 34.5 gallons, milleage capacity of 60.7 and a cost of 2000.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);