// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)capacity of \d+\.\d+(*SKIP)(*FAIL)|\d+\.\d+").unwrap();
let string = "A car has 34.5 gallons, milleage capacity of 60.7 and a cost of 2000.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}