const regex = /capacity of \d+\.\d+(*SKIP)(*FAIL)|\d+\.\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('capacity of \\d+\\.\\d+(*SKIP)(*FAIL)|\\d+\\.\\d+', 'gm')
const str = `A car has 34.5 gallons, milleage capacity of 60.7 and a cost of 2000.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}