use strict;
my $str = 'A car has 34.5 gallons, milleage capacity of 60.7 and a cost of 2000.00';
my $regex = qr/capacity of \d+\.\d+(*SKIP)(*FAIL)|\d+\.\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}