#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<word>\b\w{4,}\b)(?=.+\k<word>)?"
Local $sString = "RAMESH IS THE MASTER OF RAMESH BUT 045786 THIS RAMESH IS NOT THAT " & @CRLF & _
"NARSH IS THE MASTER OF THE WORD //04586// RAMESH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")