import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<word>\\b\\w{4,}\\b)(?=.+\\k<word>)?";
final String string = "RAMESH IS THE MASTER OF RAMESH BUT 045786 THIS RAMESH IS NOT THAT \n"
+ "NARSH IS THE MASTER OF THE WORD //04586// RAMESH";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}