$re = '/(?<word>\b\w{4,}\b)(?=.+\k<word>)?/m';
$str = 'RAMESH IS THE MASTER OF RAMESH BUT 045786 THIS RAMESH IS NOT THAT
NARSH IS THE MASTER OF THE WORD //04586// RAMESH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);