using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<word>\b\w{4,}\b)(?=.+\k<word>)?";
string input = @"RAMESH IS THE MASTER OF RAMESH BUT 045786 THIS RAMESH IS NOT THAT
NARSH IS THE MASTER OF THE WORD //04586// RAMESH";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}