import re
regex = re.compile(r"(?<word>\b\w{4,}\b)(?=.+\k<word>)?", flags=re.MULTILINE)
test_str = ("RAMESH IS THE MASTER OF RAMESH BUT 045786 THIS RAMESH IS NOT THAT \n"
"NARSH IS THE MASTER OF THE WORD //04586// RAMESH")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")