const regex = /(?<word>\b\w{4,}\b)(?=.+\k<word>)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<word>\\b\\w{4,}\\b)(?=.+\\k<word>)?', 'gm')
const str = `RAMESH IS THE MASTER OF RAMESH BUT 045786 THIS RAMESH IS NOT THAT
NARSH IS THE MASTER OF THE WORD //04586// RAMESH`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}