#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?![^<>]*\/\s*>)([a-zA-Z]+)(?:\s+[^\/<>"=\s]+(?:=(?:"[^<>"]*"?|[^=<>"\s]*"?)?)?)*>"
Local $sString = "should match the following" & @CRLF & _
"" & @CRLF & _
"<ref>" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com">" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com" name2>" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com" name2=>" & @CRLF & _
"<ref name=gbtribune.files.wordpress.com>" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com>" & @CRLF & _
"<ref name=gbtribune.files.wordpress.com">" & @CRLF & _
"" & @CRLF & _
"should not match the following:" & @CRLF & _
"<ref />" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com" />" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com" name2 />" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com" name2= />" & @CRLF & _
"" & @CRLF & _
"<ref/>" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com"/>" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com" name2/>" & @CRLF & _
"<ref name="gbtribune.files.wordpress.com" name2=/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")