using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?![^<>]*\/\s*>)([a-zA-Z]+)(?:\s+[^\/<>""=\s]+(?:=(?:""[^<>""]*""?|[^=<>""\s]*""?)?)?)*>";
string input = @"should match the following
<ref>
<ref name=""gbtribune.files.wordpress.com"">
<ref name=""gbtribune.files.wordpress.com"" name2>
<ref name=""gbtribune.files.wordpress.com"" name2=>
<ref name=gbtribune.files.wordpress.com>
<ref name=""gbtribune.files.wordpress.com>
<ref name=gbtribune.files.wordpress.com"">
should not match the following:
<ref />
<ref name=""gbtribune.files.wordpress.com"" />
<ref name=""gbtribune.files.wordpress.com"" name2 />
<ref name=""gbtribune.files.wordpress.com"" name2= />
<ref/>
<ref name=""gbtribune.files.wordpress.com""/>
<ref name=""gbtribune.files.wordpress.com"" name2/>
<ref name=""gbtribune.files.wordpress.com"" name2=/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}