const regex = /<(?![^<>]*\/\s*>)([a-zA-Z]+)(?:\s+[^\/<>"=\s]+(?:=(?:"[^<>"]*"?|[^=<>"\s]*"?)?)?)*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?![^<>]*\\\/\\s*>)([a-zA-Z]+)(?:\\s+[^\\\/<>"=\\s]+(?:=(?:"[^<>"]*"?|[^=<>"\\s]*"?)?)?)*>', 'gm')
const str = `should match the following
<ref>
<ref name="gbtribune.files.wordpress.com">
<ref name="gbtribune.files.wordpress.com" name2>
<ref name="gbtribune.files.wordpress.com" name2=>
<ref name=gbtribune.files.wordpress.com>
<ref name="gbtribune.files.wordpress.com>
<ref name=gbtribune.files.wordpress.com">
should not match the following:
<ref />
<ref name="gbtribune.files.wordpress.com" />
<ref name="gbtribune.files.wordpress.com" name2 />
<ref name="gbtribune.files.wordpress.com" name2= />
<ref/>
<ref name="gbtribune.files.wordpress.com"/>
<ref name="gbtribune.files.wordpress.com" name2/>
<ref name="gbtribune.files.wordpress.com" name2=/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}