re = /<(?![^<>]*\/\s*>)([a-zA-Z]+)(?:\s+[^\/<>"=\s]+(?:=(?:"[^<>"]*"?|[^=<>"\s]*"?)?)?)*>/m
str = 'should match the following
<ref>
<ref name="gbtribune.files.wordpress.com">
<ref name="gbtribune.files.wordpress.com" name2>
<ref name="gbtribune.files.wordpress.com" name2=>
<ref name=gbtribune.files.wordpress.com>
<ref name="gbtribune.files.wordpress.com>
<ref name=gbtribune.files.wordpress.com">
should not match the following:
<ref />
<ref name="gbtribune.files.wordpress.com" />
<ref name="gbtribune.files.wordpress.com" name2 />
<ref name="gbtribune.files.wordpress.com" name2= />
<ref/>
<ref name="gbtribune.files.wordpress.com"/>
<ref name="gbtribune.files.wordpress.com" name2/>
<ref name="gbtribune.files.wordpress.com" name2=/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end