import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?![^<>]*\\/\\s*>)([a-zA-Z]+)(?:\\s+[^\\/<>\"=\\s]+(?:=(?:\"[^<>\"]*\"?|[^=<>\"\\s]*\"?)?)?)*>";
final String string = "should match the following\n\n"
+ "<ref>\n"
+ "<ref name=\"gbtribune.files.wordpress.com\">\n"
+ "<ref name=\"gbtribune.files.wordpress.com\" name2>\n"
+ "<ref name=\"gbtribune.files.wordpress.com\" name2=>\n"
+ "<ref name=gbtribune.files.wordpress.com>\n"
+ "<ref name=\"gbtribune.files.wordpress.com>\n"
+ "<ref name=gbtribune.files.wordpress.com\">\n\n"
+ "should not match the following:\n"
+ "<ref />\n"
+ "<ref name=\"gbtribune.files.wordpress.com\" />\n"
+ "<ref name=\"gbtribune.files.wordpress.com\" name2 />\n"
+ "<ref name=\"gbtribune.files.wordpress.com\" name2= />\n\n"
+ "<ref/>\n"
+ "<ref name=\"gbtribune.files.wordpress.com\"/>\n"
+ "<ref name=\"gbtribune.files.wordpress.com\" name2/>\n"
+ "<ref name=\"gbtribune.files.wordpress.com\" name2=/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}