#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/dev\/disk0s2).* (\d*\.\d+)?Ti"
Local $sString = "/dev/disk0s2 3.6Ti 2.9Ti 796Gi 79% 383906083 104366287 79% /" & @CRLF & _
"/dev/disk0s3 1.2Ti 1.3Ti 796Gi 79% 383906083 104366287 79% /" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")