import Foundation
let pattern = #"(\/dev\/disk0s2).* (\d*\.\d+)?Ti"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/dev/disk0s2 3.6Ti 2.9Ti 796Gi 79% 383906083 104366287 79% /
/dev/disk0s3 1.2Ti 1.3Ti 796Gi 79% 383906083 104366287 79% /
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)