import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/dev\\/disk0s2).* (\\d*\\.\\d+)?Ti";
final String string = "/dev/disk0s2 3.6Ti 2.9Ti 796Gi 79% 383906083 104366287 79% /\n"
+ "/dev/disk0s3 1.2Ti 1.3Ti 796Gi 79% 383906083 104366287 79% /\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}