$re = '/(\/dev\/disk0s2).* (\d*\.\d+)?Ti/m';
$str = '/dev/disk0s2 3.6Ti 2.9Ti 796Gi 79% 383906083 104366287 79% /
/dev/disk0s3 1.2Ti 1.3Ti 796Gi 79% 383906083 104366287 79% /
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);