using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s*\n|([\w ]+)\n*(\1\n+)*";
string substitution = @"\2";
string input = @"we
all
have
a
unique
perspective
on
the
we all have a unique perspective on the
we all have a unique perspective on the
world
around
us
and
believe
it
or
not
world around us and believe it or not
world around us and believe it or not
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}