$re = '/\w+\s*\n|([\w ]+)\n*(\1\n+)*/m';
$str = 'we
all
have
a
unique
perspective
on
the
we all have a unique perspective on the
we all have a unique perspective on the
world
around
us
and
believe
it
or
not
world around us and believe it or not
world around us and believe it or not
';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;