import re
regex = re.compile(r"\w+\s*\n|([\w ]+)\n*(\1\n+)*", flags=re.MULTILINE)
test_str = ("we\n"
"all\n"
"have\n"
"a\n"
"unique\n"
"perspective\n"
"on\n"
"the\n"
"we all have a unique perspective on the\n\n"
"we all have a unique perspective on the\n"
"world\n"
"around\n"
"us\n"
"and\n"
"believe\n"
"it\n"
"or\n"
"not\n"
"world around us and believe it or not\n\n"
"world around us and believe it or not\n")
subst = "\\2"
result = regex.sub(subst, test_str)
if result:
print(result)