const regex = /\w+\s*\n|([\w ]+)\n*(\1\n+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+\\s*\\n|([\\w ]+)\\n*(\\1\\n+)*', 'gm')
const str = `we
all
have
a
unique
perspective
on
the
we all have a unique perspective on the
we all have a unique perspective on the
world
around
us
and
believe
it
or
not
world around us and believe it or not
world around us and believe it or not
`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);