# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?href=")(https?:\/\/[^"]*)/$2\r/gm;t' <<< "Can support \r \n to the newline format.
<div yne-ht: 1.75; foize: 14px;\"><a href=\"https://chrome.google.com/webstore\"><span style=\"font-sit-family:57);\"> </span><a href=\"https://microsoftedge.microsoft.com/addons\"><span style>微软商店</span></a><span st 57, 57);\"> </span><a href=\"https://crx4chrome.com\" n style=\"font ><span style=\"font
!(.*?href=\")(https?://[^\"]*)!$2\r!gm
!(.*?href=\")(https?://[^\"]*)!$2\n!gm
"