import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?href=\")(https?://[^\"]*)";
final String string = "Can support \\r \\n to the newline format.\n"
+ "<div yne-ht: 1.75; foize: 14px;\"><a href=\"https://chrome.google.com/webstore\"><span style=\"font-sit-family:57);\"> </span><a href=\"https://microsoftedge.microsoft.com/addons\"><span style>微软商店</span></a><span st 57, 57);\"> </span><a href=\"https://crx4chrome.com\" n style=\"font ><span style=\"font\n"
+ "!(.*?href=\")(https?://[^\"]*)!$2\\r!gm\n"
+ "!(.*?href=\")(https?://[^\"]*)!$2\\n!gm\n";
final String subst = "$2\\r";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}