#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*?href=")(https?://[^"]*)"
Local $sString = "Can support \r \n to the newline format." & @CRLF & _
"<div yne-ht: 1.75; foize: 14px;"><a href="https://chrome.google.com/webstore"><span style="font-sit-family:57);"> </span><a href="https://microsoftedge.microsoft.com/addons"><span style>微软商店</span></a><span st 57, 57);"> </span><a href="https://crx4chrome.com" n style="font ><span style="font" & @CRLF & _
"!(.*?href=")(https?://[^"]*)!$2\r!gm" & @CRLF & _
"!(.*?href=")(https?://[^"]*)!$2\n!gm" & @CRLF & _
""
Local $sSubst = "$2\r"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)