import Foundation
let pattern = #"(.*?href=")(https?://[^"]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Can support \r \n to the newline format.
<div yne-ht: 1.75; foize: 14px;"><a href="https://chrome.google.com/webstore"><span style="font-sit-family:57);"> </span><a href="https://microsoftedge.microsoft.com/addons"><span style>微软商店</span></a><span st 57, 57);"> </span><a href="https://crx4chrome.com" n style="font ><span style="font
!(.*?href=")(https?://[^"]*)!$2\r!gm
!(.*?href=")(https?://[^"]*)!$2\n!gm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2\r"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)