# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?href=\")(https?://[^\"]*)"
test_str = ("Can support \\r \\n to the newline format.\n"
"<div yne-ht: 1.75; foize: 14px;\"><a href=\"https://chrome.google.com/webstore\"><span style=\"font-sit-family:57);\"> </span><a href=\"https://microsoftedge.microsoft.com/addons\"><span style>微软商店</span></a><span st 57, 57);\"> </span><a href=\"https://crx4chrome.com\" n style=\"font ><span style=\"font\n"
"!(.*?href=\")(https?://[^\"]*)!$2\\r!gm\n"
"!(.*?href=\")(https?://[^\"]*)!$2\\n!gm\n")
subst = "$2\\r"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.