#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[[:alnum:]+\/]{4})*(?:[[:alnum:]+\/]{2}[AEIMQUYcgkosw048]=|[[:alnum:]+\/][AQgw]==)?$"
Local $sString = "valid Base64 encoding" & @CRLF & _
"AA==" & @CRLF & _
"/w==" & @CRLF & _
"/wA=" & @CRLF & _
"//8=" & @CRLF & _
"//8A" & @CRLF & _
"////" & @CRLF & _
"" & @CRLF & _
"invalid Base64 encoding" & @CRLF & _
"A0==" & @CRLF & _
"/x==" & @CRLF & _
"/wB=" & @CRLF & _
"//9=" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")