import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[[:alnum:]+\\/]{4})*(?:[[:alnum:]+\\/]{2}[AEIMQUYcgkosw048]=|[[:alnum:]+\\/][AQgw]==)?$";
final String string = "valid Base64 encoding\n"
+ "AA==\n"
+ "/w==\n"
+ "/wA=\n"
+ "//8=\n"
+ "//8A\n"
+ "////\n\n"
+ "invalid Base64 encoding\n"
+ "A0==\n"
+ "/x==\n"
+ "/wB=\n"
+ "//9=\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}