re = /^(?:[[:alnum:]+\/]{4})*(?:[[:alnum:]+\/]{2}[AEIMQUYcgkosw048]=|[[:alnum:]+\/][AQgw]==)?$/m
str = 'valid Base64 encoding
AA==
/w==
/wA=
//8=
//8A
////
invalid Base64 encoding
A0==
/x==
/wB=
//9=
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end