const regex = /^(?:[[:alnum:]+\/]{4})*(?:[[:alnum:]+\/]{2}[AEIMQUYcgkosw048]=|[[:alnum:]+\/][AQgw]==)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[[:alnum:]+\\\/]{4})*(?:[[:alnum:]+\\\/]{2}[AEIMQUYcgkosw048]=|[[:alnum:]+\\\/][AQgw]==)?$', 'gm')
const str = `valid Base64 encoding
AA==
/w==
/wA=
//8=
//8A
////
invalid Base64 encoding
A0==
/x==
/wB=
//9=
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}